Can't get past "Green Button" setup for energy monitoring

I purchased an Aeon Z-wave energy monitor and successfully enrolled it into my panel. I just have Surety chat support enable my account for “energy monitoring” – additional $2 a month plan.

Now when I enter the portal and try to click the “Start using emPower Energy,” I get asked for my electrical provider and pick the only one correctly listed in dropdown box “PSEG Long Island,” click next and it says “Green Button is not supported by your utility.” And it brings me back to the main screen with the “Start using emPower Energy.”

Please advise – is green button mandatory in order to monitor energy devices? I certainly didn’t think so.

See screenshots below.


Green Button should not be mandatory. It looks like some of the documentation is outdated due to recent web changes, but you should be able to move on to setup.

I have enabled Energy Q90 on your panel, but your energy meter is not properly reporting a device type at the moment. You may need to remove and re-enroll the energy meter.


I’m stuck, it will not allow me to move onto setup.

Thanks for enabling Q90 for me. I got the instructions from Nathan and was going to do it tonight when I got home, saved me that step :slight_smile:

Ok, I will remove it and re-add it tonight. I did run the “fix network” last night after I enrolled it and put it onto the utility feed and it saw the sensor and registered with node type etc.

Btw, it is showing up in as a Z-wave device under the emPower/Devices area. Is there a specific way the Aeon meter should appear?

The device should be reporting as a Zwave energy meter. It is showing as an unknown device, so to it appears there are no metering devices on the account.

Removing and re-adding should solve this with Q90 enabled.

Got it, there must be some conditional logic there then – once the meter is registered correctly, it will allow the setup to continue. I shall try tonight and let you know. If this works, it’s going to be pretty awesome as I can monitor my power usage and solar feed. I will post some pics once I get it working so you guys can use it – not sure if you have anyone else doing dual Aeon meters with solar and utility.

I do not believe so, at least not that I am aware. We would appreciate that. I’m not aware of anyone using two meters yet, but I have been told by ADC this should work.


I got both meters registering! The solar reading one is wacked out. It’s night and displaying 3.3kwh, which is impossible. I’m using 2.3kwh total right now with central air running so I will have to research how to adjust that.

That aside, I noticed that I have to click on “GET READING NOW” to update the bar chart. Do you know the polling frequency that the data is sent up to I don’t want huge time gaps in my charts.

Nevermind, it is doing automatic updates. There is a 1 hour gap between time bars. That’s fine. Just need to fix the solar adjustment, the meter is thinking I am making 500,000 watts of power from my panels. Very happy with the utility readings, though.