Cannot login to and Reset Password Sends Expired Link

I setup my account through surety after setting up my IQ Panel 4. When I logged into I was prompted to setup 2FA which I did. When I went to login the page refreshes and then does nothing. I tried to reset password but I keep getting sent an expired link. I believe my account may be locked.

Hello, generally this kind of issue is caused by panel communication not successfully kicking in with yet. Your system must be communicating with in order to login to your account. I see the initialization commands for your system going through after this message was posted.

Have you tried logging in again now?

Can you try running a cellular communication test under the System Tests menu? Is the cell test successful right now?

No it just says cellular radio test timeout unfortunately.

Nevermind I am able to login now.

The panel looks like it is still having communication trouble at the moment. Try a reboot, Settings > Advanced Settings > Reboot Panel, then run a cell test again when it boots up.