App not working on my phone today

I cannot login with mobile app, it says please check your connection. Nexus 6

I stopped the app, cleared data and uninstalled with the same results. My wifes motox works fine, and i can login to the website. This was working fine until this morning.

I am not currently aware of any changes or updates in the last few days, nor any compatibility issues.

When attempting access, is your phone connected to wifi, or is it using 4G? I would suggest stopping the app, turning off (or on) wifi to and try again.

Does this have any effect?

I have a nexus deviceā€¦no problems for me with ADC mobile app.

The Nexus 6 runs android 5.0 (lollipop). Check play store for an update. Else if it worked fine, you did not update nexus 6 or app, and it now no longer works, that suggests an issue with your phone or settings.

Was on WiFi, tried cell radio with same results.

Nexus 6 running 5.0.1. Everything else is up to date, I tried again at 10:00 EST and was able to login. No clue what the rca. Thanks for the prompt response.

Interesting. So it is currently still functioning? I will forward the details to ADC just in case.