All heating/cooling schedules reset?

So I wake up this morning and the AC is cranking away much earlier than it should in two of my zones. WTF says I? I logged on to ADC and started poking around; I found that the cooling schedules for two of my thermostats had been reset to the default settings. What I had set up was blown away.

Worse, when I tried to edit them back to what they should be, the changes didn’t take until the third or fourth tries. I’d set the schedule, hit save, it would say updating but when I looked at the thermostat, there was no change to the set point. I go back to the website and look at the schedule again, it had been reset back to default one more time.

This went on for a few iterations until I started saving the schedules a little bit at a time, saving, forcing a thermostat update and then going back onto the site to set up a few more days of the schedule. Rinse, repeat. Over and over.

I guess I should be thankful that one of the three hadn’t been reset.

What the hell is going on over at ADC?

Guess I spoke too soon. The heating schedule was indeed reset on all three thermostats, and worse, I’m unable to save changes. Oh they look like they save just fine but if you go back into the schedule to check it, it’s all reset to defaults again.

After the fifth or sixth time of trying this, I quit.

Someone better get their shit together over there. I’m getting tired of dealing with heating and cooling issues over and over.

None of my Config/schedule settings for the T2000 have changed (so doesn’t appear to be across the board for

To my knowledge, all schedules/data for the tstat is stored locally on the panel.

Methinks that you have an issue with your Qolsys panel. Might want to check your other zwave device rules/schedules…

All the other z-wave settings are fine, the lighting schedules are unchanged etc., I did look. The schedules may be stored on the panel, but they’re only programmed via the ADC website so not sure how that would happen from the panel side as there’s zero access to them there.

Good that yours are OK though so maybe it’s not across the board. I wonder if it has to do with ADC testing/working on the whole busted notification thing that I’ve been experiencing. If that’s the case though it would be nice to know if there’s destructive testing happening.

I am getting frustrated though with the communication issues I’m constantly having with relation to the thermostats.

Well good luck.

The way I understand it, is the schedule is run locally after it is downloaded from ADC to panel. If it is then somehow corrupted/wiped out, then of course the customized schedule is gone, and I would think the default schedule would then be downloaded, and go in effect.

There are certain unfixed glitches with the tstat that only affect Qolsys, so it very well could be changes on your panel wiped out the schedule, and perhaps other Qolsys users that also have the T2000 (or other tstat?) can confirm.

There are certain unfixed glitches with the tstat that only affect Qolsys, so it very well could be changes on your panel wiped out the schedule

There are definitely challenges with the T2000 and Qolsys, that’s for sure. The scheds were changed on the ADC site though and not sure how the panel would be able to reset those; the logical assumption would be that if it broke on the stat that I should be able to just resent with the “good” data from the website. You know what they say about assumptions though…

This is ongoing still…I can’t set a schedule on the site and have it stay sticky. It says saved and as soon as I go back into it, boom reset.

Try a reset.

Unpair tstat(s).

Then physically reset each tstat, then pair and configure one at a time.

Is this issue occurring currently?

Indeed, it may have been a result of troubleshooting. Although it may also be a symptom of the same problem occurring with notifications. This is being worked on currently.

If you are still having trouble setting schedules, are you able to reliably send other commands to the thermostats? Can you remotely change target temp 5-6 times and it work every time?

No, it’s still all over the place. Now though there’s a bonus, it’s automatically going from a seven day schedule to a two day (week, weekend).

If I successfully create a schedule on one thermostat then it seems to stick but then I try to copy that to the other two and they look OK at first…until I try to make whatever tweaks differentiate one from the other then they revert back to some default set up or the two day/seven day deal.

I’m unable to effect any thermostat change from the website currently, so now it appears that all three of my zones are blasting away in cooling mode, completely ignoring the smart away even at this point.

What does still seem to work though is the setting of temps manually through the app. At least it appears so, who knows what’s really happening in the house at this point.

Also, schedule edits appear to be sticky in the app as well, so it’s the website that’s suffered terminal brain damage.

Again, it APPEARS to be the case. I don’t believe or trust anything that I’m being presented right now.

Can you verify which commands are taking effect properly? Did your adjusted schedules run as they should have?

So do you have no trouble setting schedules through the app?

I would recommend clearing your browser cache completely, then try again, if the app functions and website does not. Does this help?

Increasing or decreasing target worked fine as well as setting schedules. The errors on the site happened from two different locations on two different machines with two different operating systems and two different browsers. Not a cache or cookie issue.

Fair enough. I have to ask.

Other functions through the website work fine? Arming/disarming/user code management? is working on this currently but haven’t yet been able to replicate it.

When you were resending schedules, or trying to rather via the web, how long were you waiting for those to take effect? Schedule commands can take a few minutes to register. Just to rule it out, did you wait for a few minutes before checking?

I didn’t wait a few minutes to check the schedules again if that’s what you mean. I’d edit a schedule, save it, then hit the refresh icon on the thermostat in question. After it finished “updating” and said “current” on the thermostat, I’d go look at the schedule again and it would have reverted back. I don’t know what was sent or not sent as I wasn’t home. What I did see though was the indicated temperature was indeed dropping when it shouldn’t have been and that was telling me that the system was cooling.

I tried various ways to shock it into reality including refreshing scheds, turning sheds on and off, going from two day to seven day programming etc. Each time I’d make a change, I’d hit the refresh button on the web.

Speaking of indications, here’s a feature request: Show on the web or in the app whether or not the system is “on” and in what mode, heating or cooling.

So you tried everything except actually resetting the tstats? Perhaps you should try that. When my T2000 started glitching (changing temp that was not scheduled, or manually set), I reset the tstat, and it started working normally.

The refresh icon on the thermostat page will only update the current temp on the page. If schedules were not successfully acknowledged by the Tstats yet, that might be part of the problem.

I would also recommend a reset of the thermostats here as a next step after testing cell (from other thread).

So you tried everything except actually resetting the tstats? Perhaps you should try that. When my T2000 started glitching (changing temp that was not scheduled, or manually set), I reset the tstat, and it started working normally.

Yes, that’s right, I didn’t reset the stats again. I don’t know how or why the thermostat would bork the schedule online and no one can explain that to my satisfaction either. once I was able to reset the schedules, the stats are following the new (old) schedules including the smart away settings.

Resetting everything, again, is a real pain in the you know what. I want to stress that they’re working fine according to the schedules that they see, the issue is one of reporting status and schedules online disappearing. Also, the random switching of 2 day to seven day schedules…how is that going to be fixed by the thermostat being reset? That function is only available as an option online or in the app. You can’t see or touch that in the panel or on the stats.

This happened to ALL THREE thermostats in my system. if it was only one then I could maybe swallow that but to have all three suffer the same symptoms points to a back end error, not a device error. I don’t mind troubleshooting but doing the same thing that’s been tried before, over and over again, doesn’t seem productive unless someone can point to a definitive reason that should fix it.