Adding ADC-V510 camera

It’s not online with ADC; that’s the problem. It won’t provision.

I realize the cam is discontinued, and if support for it is also discontinued I’ll be moving on to a better system entirely. I made the switch to Surety primarily because it didn’t require much investment to convert from Vivint. If I have to start buying new equipment then the system will go in the trash.

It’s not online with ADC; that’s the problem. It won’t provision

Well, good luck then


I’m not trying to be rude, but I’ve already explained that I’ve tried that several times. This is beyond anything I can do, as has already stated this is a known issue. There is absolutely no way to provision this thing right now. I’m dead in the water due to the factory reset I performed on the unit, and I have to wait for them to resolve the problem on their end.

You cannot manually add it by MAC. If I put in the MAC and click refresh or Next or anything I can possibly click, it just moves onto the next step with the detected camera since that is the only thing showing up in the list with a bubble next to it.

The fact that I can’t manually provision this thing and configure the backend myself via SSH or web UI is beyond frustrating. They’ve oversimplified the process of adding a camera to the point where any manual intervention outside the “wizard” is impossible.

The V510 is not sold as a new camera, and is not compatible with the new ADC SVR recorder, but it is still supported as of now. is looking into the issue, it is not a long standing issue and was only discovered within the last day or so.

I will follow up tomorrow to see if there are any updates or ETA for you. It is also possible that an additional workaround is found.


As a follow up: the workaround is currently to power cycle the camera a few times and try to assign it to your account. For some reason the V510s are currently experiencing trouble establishing full connection during the pairing process.

It looks like you were able to get it re-installed. I see a 510 on your account. Is that correct?

I don’t think there is any sort of “workaround” as all I did was attempt to add it one more time and it finally worked. has obviously got some issues on their end but they seem to be at least partially resolved at this time. The camera is again added and working. Thanks!