ADC-T40K-HD set time

Just bought a house that has two of these. I don’t have nor want an alarm.com account, the stats are nice but I can’t seem to set the time so the salutation display corresponds to the time. ie : says “good afternoon” when it should say “good evening”

Regards, Scott

Happy to assist!

Unfortunately, I do not have one in front of me to confirm, but you should be able to adjust the time locally (without service) by the following method:

  1. Tap the Menu icon on the T40K
  2. Tap User Settings.
  3. Tap Schedule.
  4. Tap Edit Schedule.
  5. Tap to select the time and day.
  6. Tap Save

@tyler I do not have that option under user settings. Perplexed.

It may only be available if the TSTAT is connected to a panel, is it?

Connected to panel meaning white thing behind it and HVAC system

No, an alarm panel with Z-Wave radio. Typically the T40K gets time information from the Z-Wave network.

The T40K is an Alarm.com Z-Wave Thermostat meant to be connected to an Alarm.com compatible alarm panel (with service) for full use of the TSTAT.

No it is not. That is absurd though. It is connected via z wave though.

What’s it connected to via z-wave? Typically that would be the alarm system.

Home assistant

When unit is connected to zwave to any hub or panel time set up will not be available its pull through the panel.

To manually set up time you have to exclude device from the panel / home assist

Oh man what a pita. Thanks for that. Will give it a go.