ADC rules not working (2Gig panel)

I’ve created a couple simple rules on ADC (turn on interior lights when door opens, turn on exterior lights at a specific time, disarm panel when door is unlocked), but none of them “work”. I have a 2Gig CP, and I’ve verified that Q79 is set to 3. I’ve also rebooted the panel.

This is the first time I’ve experimented with rules, so this is not a “new” problem. (In other words, I’ve never had rules working before, since this is the first time I’ve tried). I suspect there is a setting with ADC or the CP that’s not enabling the rules to download to the panel.


When you use quotations, do you mean that the rules have never functioned since creation?

What is the network topology? Is your 2Gig panel the only dedicated controller?

Certainly is odd that none of those rules would function. How long before this post were these rules created?

The rules themselves you’ll want to allow a little time to register. Typically it is quick, but not always.

Hi Jason.

What I was trying to say is that while I’ve had a functional ADC/2Gig alarm systems for a couple years, I’m just now getting started with Z-wave automation, so I don’t have any history of rules working, or not. (My actual 2Gig panel is just a couple weeks old, replaced when the original malfunctioned). So you are correct, these rules have never functioned since creation, and I’ve never had any rules function (since these are the first I’ve tried).

Over the last few weeks, I’ve experimented with using a SmartThings hub as a primary controller, with 2Gig panel as a secondary, but I gave up on that approach for various reasons. Currently, I have a few Z-wave devices assigned to the SmartThings hub (which is in turn paired with a Logitech Home Control hub), and the remainder assigned to the 2Gig panel (two separate Z-wave networks, with no overlap between them). This configuration was created after removing all devices, resetting the 2Gig panel z-wave state, and then re-learning the devices. I also have the 2Gig bridge installed and functional.

All devices work as expected (I can control them from the panel, from the ADC web interface, or via my phone app). And I’m able to build the rules on the ADC web interface without any trouble. They just don’t seem to do anything.

Most of the rules were built on Saturday, with a “test” rule built on Sunday. In all cases, the rules were built at least several hours prior to my post.

For what it’s worth, I have a Z-wave thermostat, and it responds to “rules” on the thermostat control tab (Arm away override, etc.) just fine.

Alright, well in that case we can tackle each individually.

The Door Lock disarm rule requires a lock model which can update 2Gig with the exact user code that unlocked the door. When you unlock your door, do you see ADC report it was “unlocked by ‘so and so’” or just “unlocked?”

The light rule is strange however, given how simple it is. Can you create a new rule for a different light based on sensor activity for any of the doors, wait ten minutes and test it? Any positive result?

It does outwardly appear that ADC rules are simply not being captured and stored properly Panel-Side.

Regarding the locks – for some reason, I’ve only got a couple days of history on ADC (maybe it was purged when I reset the z-wave function), but over those last couple days there are two entries that say “Front Door Lock (ID:14)” “Unlocked by [my wife’s name]”. I’ll do some testing tonight when I get home, to make sure it recognizes different user codes, but at first blush, it does seem to be recognizing user codes.

With regards to the light-based rules – I did try a couple different ones yesterday as a test, to no avail. But I’ll try a few more tonight and let you know what happens.

Alright, yes if you could let me know which type of rule and how many you create (and whether or not they work) now I will get in contact with ADC and let them know which are not being properly communicated to your system.

I say this because deleting and recreating/trying new rules will always be the best first step to rule out equipment issues or intermittent signal. It sounds possible that something else is going on in this case though.

I have verified that the ADC history indicates “door unlocked by [User Name]”, with either of the two user codes that I’ve established (via the ADC “users and contacts” page).

I then deleted all existing rules on ADC, and rebuilt three new rules:

  1. Turn on an interior light when door opens.

  2. Disarm panel when door unlocked by user.

  3. Turn on interior lights based on a simple time-of-day schedule.

I then waited about 15 minutes, and tested all of them. None worked.

Here’s something that occurs to me – not sure if it’s related. When I first started looking at installing Z-wave stuff a couple months ago, I didn’t have any emPower screens on my account at all. I called you guys (SuretyCam), and the person I spoke to made some sort of change to my settings which allowed the emPower screens to be visible. Perhaps there is another related setting that didn’t get adjusted?

Anyway, please let me know what I should try next.


Well, I’d like to try to send a couple of commands to your system to see if we can kick start the rules and eliminate a few problem possibilities. Can I send a hard reset and a few Zwave status checks?

Yes, please go ahead. I assume this testing won’t require me to be physically at the panel?

I am also noticing ADC empower rule malfunctions (light automation)…

Good news – rules are working this evening. Not sure if this was spontaneous, or if was prompted by something you did on your end, but it seems that the problem is solved. So thank you!

A command to rebuild all rules was sent to the panel and the issue was escalated to engineers. Apparently they found the root fast. Good to hear you are up and running.

Keep us updated if you notice any other issues.