2gig edge controller siren not working

Hi,

A few nights ago the alarm was triggered in the middle of the night and the Siren did not play…it caused the police department to knock on my door (I leave my phone on mute at night)

I used the test feature and when playing it does not sound…I restarted the controller and same luck. Do you have any suggestions?

Also, are the secondary panels also supposed to play the siren when there is an alarm triggered? mine do not…is there a setting that I am missing?

Thanks,
Felipe

There is a disable sounder option in settings under the tests section that allows you to disable the siren temporarily.

You can also set the siren to remain off after 2-Way Voice in settings. It looks like you have this enabled. It is Q106

If you test an alarm now, how do the sounders behave on the panel and secondary panels?

Hi Jason

I did not disable the siren using that option.

Modified Q106 and still no luck

I tested the alarm, by arming the system and opening a window…I only audio feedback was voice on the panel, no Siren on main or secondary panels.

I can test the Siren on secondary panels and it makes sound.

Any other suggestions/ideas?

Thanks

I’m not aware of any other setting that would completely halt siren activation. When you opened the window, an alarm did register on the panel, correct? The siren just did not sound?

Have you tried power cycling that panel? Power down the main panel for at least 20 minutes. After, boot it back up and test again.

How long is the power cable for the panel?

Did the siren ever work on that panel?

  1. Correct, alarm registers but siren does not play…on main panel nor secondary panels (is it supposed to play on secondaries?, is there a setting?)

  2. tried … no improvement

  3. I would say 9 -10 feet… tried also on battery, no luck.

  4. yes, the siren used to work

any more ideas?

Thanks,
Felipe

is it supposed to play on secondaries?, is there a setting?

Yes, it should sound. No, I am not aware of any other settings which might halt all siren activation on the panel or keypads. This sounds like a bug.

Can we push a firmware update? Your panel appears to be on launch firmware.

yes please…push an update
Thanks

Alright that is being sent via broadband. Please ensure your panel remains powered on. It should be complete within 20 minutes to an hour usually.

I think it did not work…the panel was on tamper…may have to send it again …unless it keeps trying

Your panel reports that it is successfully updated on the new firmware.

it did…and no luck…whats next? contact 2gig? thanks